PHPMotion en Plesk – Instalación y Errores

logo_plesk

Instalar PHPmotion en Plesk con Debian

**Nota: Cabe mencionar que los siguientes datos y problemas resueltos le pueden servir para instalar phpmotion en plesk, cpanel, debian o centos, da igual, pueden ocurrir los mismos errores, menos la parte de des instalar plesk que no tiene que pasar ni en plesk , así que esta guía les puede funcionar como base para resolver los mismos problemas en otros paneles y sistemas operativos, y si luego de esto no pueden resolver el problema y si necesitan un sysadmin contáctenos a soporte[arroba]servitecweb[punto]net par un presupuesto **

Bueno, hoy toco otra vez alistar un server para un site similar a youtube, con vídeo encoding y todas esas opciones, ya he trabajado con 3 script de estos, en anteriores ocasiones varias veces con vshare y con otro plugin de pago que no recuerdo como se llama bien pero que me ha gustado bastante por la interfaz que tiene, aunque bueno, los script son lo de menos, la función de todos es similar y los requisitos también, requisito menos requisitos más.

Y bueno en este caso y como siempre tuve problemas con plesk, la última vez que instale un script similar fue en plesk con centos y no fue nada complicado hacer funcionar el plesk, lo único que tuve que hacer fue desactivar el open basedir y poco mas, ya que fue con vshare y este usa php5-ffmpeg y es realmente fácil hacerlo funcionar todo.

Por otro lado phpmotion usa perl para interactuar con mencoder y demás herramientas de encoding, aunque esto no quiere decir que sea complicado hacerlo funciona, no, nada de eso, pero surgen errores tontos que si no pones atención puede que te den ganas de tirar el pc por la ventana con todo y server y demás.

Así que bueno comenzamos con la instalación:

Instalar FFMPEG y Requisitos de PHPMOTION

Para instalar los requisitos, se puede usar apt-get, que en debian los repos son mas completos que en centos y no hay ningún problema, aunque en este caso yo use el script que les deje hace poco: Scrip para compilar / instalar FFMPEG con x264 en Linux – Debian y Centos

Bien con ese script instalo todo, aunque me falto flvtool2, aunque no me quise complicar la vida y lo instale con apt-get:

apt-get install flvtool2

Por otro lado si no queremos compilar que tarda más aunque nos dará un mejor rendimiento podemos instalar todo con apt: apt-get install ffmpeg mencoder, flvtool2 etc

Un detalle interesante: Con el script, al hacer apt-get update no se por que me desinstalo algunos paquetes de plesk y este dejo de funcionar, es muy raro pero me paso, cosa que nunca me había pasado antes, aunque bueno no fue con el update, fue con el apt-get install TODOS LO COMPILDORES, asumo que se desinstalo por que tenia un apt-get -y paquetes, seguro ahí me pregunto que si quería desinstalar paquetes y se auto respondió con un si, así que el plesk quedo off y dañado… Luego de compilar todo tuve que reparar el plesk y fue bastante sencillo:

***Use lo siguiente bajo su responsabilidad en entornos en producción ****

Desinstalar plesk y volverlo a instalar sin formatear

Primero bajamos este script :

wget http://kb.parallels.com/Attachments/18064/Attachments/plesk_remove.zip

Luego descomprimimos:

unzip plesk_remove.zip

Luego ejecutamos:

sh plesk_remove.sh

Aceptamos y esperamos menos de un minuto.

Luego lo volvemos a instalar con el auto instalador automático:

OJO esto es para la ultima versión, si teníamos plesk 10 y ejecutamos esto pueden pasar cosas muy malas, usen bajo su propio riesgo.

wget -O - http://autoinstall.plesk.com/one-click-installer | sh

Bueno, primero decir que este proceso no me daño nada, o sea los dominios, claves, bases de datos, archivos de dominios todo estaba ahí, igual no les recomiendo que le hagan, lo dejo aquí por si instalando requisitos de phpmotion o algún otro script por error borran plesk o algún componente puedan intentar repararlo con este método, que, por supuesto, usaran bajo su propio riesgo 🙂

Continuar leyendo «PHPMotion en Plesk – Instalación y Errores»

Script para compilar / instalar FFMPEG con x264 en Linux – Debian y Centos

1533743527_fca3d440d7

Compilar FFMPEG – PHP-FFMPEG – MPLAYER – GIT – LAME – LIBOGG – LIBVORVIS – XVIDCORE – YASM

He estado personalizando algunas tareas para facilitarme la vida instalar algunas cosillas que me pide la gente así que he hecho un pequeño script para compilar FFMPEG con x264 y demás dependencias.

Tal cual como se los dejo funciona solo en debian, para centos tengo que cambiar la parte de apt, que instala el compilador y las dependencias de este mismo, lo demás lo compila sin problemas, aunque hoy no lo voy a hacer ya que me gusta probarlo y no tengo tiempo para montar un VPS con centos ahora mismo, pero tarde o temprano lo haré.

Si bien es cierto que se puede instalar mediante apt-get install ffmpeg pero, no lo instala todo y con el scritp compilamos y tendremos mejor rendimiento y también no tenemos que buscar los repos para todo, que si bien en debian vienen por defecto todos los paquetes y podemos instalar con apt-get o aptitude sin problemas con los repos por defecto, en centos es un poco más complicado y hay que buscar repos, así que este script le será más útil a los que tienen servidores centos ( cuando este funcionando para centos que son dos tonterías y funciona ) que a la gente de debían que lo pueden instalar por apt, aunque, a día de hoy el script instala las últimas versiones de los paquetes, los cuales puede que no estén en la última versión de los repos.

Continuar leyendo «Script para compilar / instalar FFMPEG con x264 en Linux – Debian y Centos»

Instalar YUM en Centos 6 – VPS – Virtuozzo – OpenVZ

Instalar Yum En Centos 6

Hoy otra vez me toco instalar YUM en un VPS con Centos 6 que no es nada complicado, pero las dependencias siempre cambian ya se por que a cambiado la versión o por que el mirror no esta y ninguno de los enlaces que tenia guardados me ha funcionado, ni una sola dependencia online, así que me toco buscar y rebuscar las dependencias, que las he podido descargar desde este enlace en centos.org

Si bien ahí se pueden obtener siempre hay que buscarlas y si copias los enlaces y los guardas seguro que no te funcionarán por que cambiará la versión y hay que buscarlas otra vez, así que por eso hago este tema, para dejar guardada una versión que iré actualizando cada cierto tiempo.

Las dependencias para instalar yum son básicamente estas:

gpgme
pygpgme
python-iniparse
python-pycurl
python-urlgrabber
rpm-python
yum
yum-metadata-parser
yum-plugin-fastestmirror

Bien, todo esto lo podemos descargar desde este enlace: mirror.skamasle.com/vz/yum-dep

Descargamos las dependencias y luego nos ubicamos en la carpeta en donde estén todas y ejecutamos:

rpm -Uhv *.rpm

Con eso tendremos YUM funcionando.

Por otro lado esto pasa en debian a veces, que no esta instalado apt-get y tenemos que usar dpkg para instalarlo, así que más adelante dejaré los .deb y todas las dependencias, no lo hago ahora por que no me apetece buscarlas, pero cuando me hagan falta otra vez, las tendrán por aquí.

En fin, espero les sirva a los que tienen un VPS nuevo o han des-instalado medio sistema por error y se han cargado el yum también…. ( si a veces pasa :/ )

Edito:

Instalar Yum en Debian 6

Muchas búsquedas y preguntas al correo sobre como instalar yum en debian 6, aquí les dejo la respuesta:

En debian no se puede instalar YUM, ese comando es el gestor de paquetes de centos, debian tiene su propio gestor de paquetes, en vez de YUM instenten usar apt-get o aptitude, ese es el gestor de paquetes y ahí podrán instalar lo que quieran:

apt-get update -> para actualizar los repos.
apt-get install perl -> para instalar perl.
etc

Espero les sirva la info 🙂