Fix Plesk – LetsEnCrypt en Centos 6 error (Python 2.6)

LetsEncrypt no soporta python 2.6 ( versión por defecto de centos 6 ), lo cual es un problema bastante importante para algunos, ya que centos 6 tiene soporte para varios años más y mucha gente sigue usandolo centos 6 con plesk el problema es que no se puede actualizar python 2.6 ya que si se hace se rompe el sistema principalmente yum, esto ya lo sabemos pero tenia que decirlo por si alguien no lo sabe y el otro día me tope con este error en plesk 12.5 con centos 6 y el modulo letsencript instalado desde el catalogo de módulos de plesk

Así que si usamos Plesk con centos 6 y hemos instalado letsencrypt puede que nos salga este feo error:

Error: Error de instalación del certificado SSL Let’s Encrypt: Failed letsencrypt execution: /usr/local/psa/var/modules/letsencrypt/venv.xxxx/lib/python2.6/site-packages/cryptography/__init__.py:25: DeprecationWarning: Python 2.6 is no longer supported by the Python core team, please upgrade your Python.

El error completo:

Continuar leyendo «Fix Plesk – LetsEnCrypt en Centos 6 error (Python 2.6)»